#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^!NAME:\s+"(Slot.*?)""
Local $sString = "!NAME: "Slot 10 SubSlot 0"" & @CRLF & _
"!NAME: "Slot 4"(this works, but the capture string will not always be this small)" & @CRLF & _
"!NAME: "Slot 4 Subslot 12 Internal Subslot 14 External"" & @CRLF & _
"!NAME: "Slot 75 Internal Slot 12 External"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")