re = /^!NAME:\s+"(Slot.*?)"/m
str = '!NAME: "Slot 10 SubSlot 0"
!NAME: "Slot 4"(this works, but the capture string will not always be this small)
!NAME: "Slot 4 Subslot 12 Internal Subslot 14 External"
!NAME: "Slot 75 Internal Slot 12 External"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end