import Foundation
let pattern = #"^!NAME:\s+"(Slot.*?)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
!NAME: "Slot 10 SubSlot 0"
!NAME: "Slot 4"(this works, but the capture string will not always be this small)
!NAME: "Slot 4 Subslot 12 Internal Subslot 14 External"
!NAME: "Slot 75 Internal Slot 12 External"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)