$re = '/^!NAME:\s+"(Slot.*?)"/m';
$str = '!NAME: "Slot 10 SubSlot 0"
!NAME: "Slot 4"(this works, but the capture string will not always be this small)
!NAME: "Slot 4 Subslot 12 Internal Subslot 14 External"
!NAME: "Slot 75 Internal Slot 12 External"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);