using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^!NAME:\s+""(Slot.*?)""";
string input = @"!NAME: ""Slot 10 SubSlot 0""
!NAME: ""Slot 4""(this works, but the capture string will not always be this small)
!NAME: ""Slot 4 Subslot 12 Internal Subslot 14 External""
!NAME: ""Slot 75 Internal Slot 12 External""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}