// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^!NAME:\s+"(Slot.*?)""#).unwrap();
let string = "!NAME: \"Slot 10 SubSlot 0\"
!NAME: \"Slot 4\"(this works, but the capture string will not always be this small)
!NAME: \"Slot 4 Subslot 12 Internal Subslot 14 External\"
!NAME: \"Slot 75 Internal Slot 12 External\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}