use strict;
my $str = '!NAME: "Slot 10 SubSlot 0"
!NAME: "Slot 4"(this works, but the capture string will not always be this small)
!NAME: "Slot 4 Subslot 12 Internal Subslot 14 External"
!NAME: "Slot 75 Internal Slot 12 External"
';
my $regex = qr/^!NAME:\s+"(Slot.*?)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}