#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)\b(?:hap+y+\s*b(?:irthday+|da?y+)|HBD+)\b(?:\s*to\s*([^\d\s]+))?"
Local $sString = "happy birthday" & @CRLF & _
"happy birthdayyyyy" & @CRLF & _
"happy birthday!" & @CRLF & _
"happy bdyyy" & @CRLF & _
"happy bdayyy" & @CRLF & _
"hbd" & @CRLF & _
"HBDD" & @CRLF & _
"happy birthday" & @CRLF & _
"happyyyy birthdayyyy" & @CRLF & _
"happy happy birthday " & @CRLF & _
"a very happy birthday " & @CRLF & _
"i wish you a very happy birthdayyy" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")