import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b(?:hap+y+\\s*b(?:irthday+|da?y+)|HBD+)\\b(?:\\s*to\\s*([^\\d\\s]+))?";
final String string = "happy birthday\n"
+ "happy birthdayyyyy\n"
+ "happy birthday!\n"
+ "happy bdyyy\n"
+ "happy bdayyy\n"
+ "hbd\n"
+ "HBDD\n"
+ "happy birthday\n"
+ "happyyyy birthdayyyy\n"
+ "happy happy birthday \n"
+ "a very happy birthday \n"
+ "i wish you a very happy birthdayyy\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}