import Foundation
let pattern = #"(?i)\b(?:hap+y+\s*b(?:irthday+|da?y+)|HBD+)\b(?:\s*to\s*([^\d\s]+))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
happy birthday
happy birthdayyyyy
happy birthday!
happy bdyyy
happy bdayyy
hbd
HBDD
happy birthday
happyyyy birthdayyyy
happy happy birthday
a very happy birthday
i wish you a very happy birthdayyy
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)