re = /(?i)\b(?:hap+y+\s*b(?:irthday+|da?y+)|HBD+)\b(?:\s*to\s*([^\d\s]+))?/m
str = 'happy birthday
happy birthdayyyyy
happy birthday!
happy bdyyy
happy bdayyy
hbd
HBDD
happy birthday
happyyyy birthdayyyy
happy happy birthday
a very happy birthday
i wish you a very happy birthdayyy
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end