const regex = /(?i)\b(?:hap+y+\s*b(?:irthday+|da?y+)|HBD+)\b(?:\s*to\s*([^\d\s]+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\b(?:hap+y+\\s*b(?:irthday+|da?y+)|HBD+)\\b(?:\\s*to\\s*([^\\d\\s]+))?', 'gm')
const str = `happy birthday
happy birthdayyyyy
happy birthday!
happy bdyyy
happy bdayyy
hbd
HBDD
happy birthday
happyyyy birthdayyyy
happy happy birthday
a very happy birthday
i wish you a very happy birthdayyy
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}