use strict;
my $str = 'happy birthday
happy birthdayyyyy
happy birthday!
happy bdyyy
happy bdayyy
hbd
HBDD
happy birthday
happyyyy birthdayyyy
happy happy birthday
a very happy birthday
i wish you a very happy birthdayyy
';
my $regex = qr/(?i)\b(?:hap+y+\s*b(?:irthday+|da?y+)|HBD+)\b(?:\s*to\s*([^\d\s]+))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}