using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b(?:hap+y+\s*b(?:irthday+|da?y+)|HBD+)\b(?:\s*to\s*([^\d\s]+))?";
string input = @"happy birthday
happy birthdayyyyy
happy birthday!
happy bdyyy
happy bdayyy
hbd
HBDD
happy birthday
happyyyy birthdayyyy
happy happy birthday
a very happy birthday
i wish you a very happy birthdayyy
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}