import re
regex = re.compile(r"(?i)\b(?:hap+y+\s*b(?:irthday+|da?y+)|HBD+)\b(?:\s*to\s*([^\d\s]+))?", flags=re.MULTILINE)
test_str = ("happy birthday\n"
"happy birthdayyyyy\n"
"happy birthday!\n"
"happy bdyyy\n"
"happy bdayyy\n"
"hbd\n"
"HBDD\n"
"happy birthday\n"
"happyyyy birthdayyyy\n"
"happy happy birthday \n"
"a very happy birthday \n"
"i wish you a very happy birthdayyy\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")