# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:(laugh|mmmm|smile):/<img src="images\/smileys\/$1.png" class="$1">/g;t' <<< "Hey my dear :laugh: how are you :mmmmm: :smile: and non existing smile :go: "