import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":(laugh|mmmm|smile):";
final String string = "Hey my dear :laugh: how are you :mmmmm: :smile: and non existing smile :go: ";
final String subst = "<img src=\"images/smileys/$1.png\" class=\"$1\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}