$re = '/:(laugh|mmmm|smile):/';
$str = 'Hey my dear :laugh: how are you :mmmmm: :smile: and non existing smile :go: ';
$subst = "<img src=\"images/smileys/$1.png\" class=\"$1\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;