use strict;
my $str = 'Hey my dear :laugh: how are you :mmmmm: :smile: and non existing smile :go: ';
my $regex = qr/:(laugh|mmmm|smile):/p;
my $subst = '<img src="images/smileys/$1.png" class="$1">';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";