const regex = /:(laugh|mmmm|smile):/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':(laugh|mmmm|smile):', 'g')
const str = `Hey my dear :laugh: how are you :mmmmm: :smile: and non existing smile :go: `;
const subst = `<img src="images/smileys/$1.png" class="$1">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);