// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r":(laugh|mmmm|smile):").unwrap();
let string = "Hey my dear :laugh: how are you :mmmmm: :smile: and non existing smile :go: ";
let substitution = "<img src=\"images/smileys/$1.png\" class=\"$1\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}