#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ":(laugh|mmmm|smile):"
Local $sString = "Hey my dear :laugh: how are you :mmmmm: :smile: and non existing smile :go: "
Local $sSubst = "<img src="images/smileys/$1.png" class="$1">"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)