using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(laugh|mmmm|smile):";
string substitution = @"<img src=""images/smileys/$1.png"" class=""$1"">";
string input = @"Hey my dear :laugh: how are you :mmmmm: :smile: and non existing smile :go: ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}