using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#[0-9]*=";
string substitution = @"<a href='$&'>$&</a>";
string input = @"#1=stuff
#2=more stuff
...
#123=even more stuff";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}