import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#[0-9]*=";
final String string = "#1=stuff\n"
+ "#2=more stuff\n"
+ "...\n"
+ "#123=even more stuff";
final String subst = "<a href='$&'>$&</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}