const regex = /^#[0-9]*=/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#[0-9]*=', 'gm')
const str = `#1=stuff
#2=more stuff
...
#123=even more stuff`;
const subst = `<a href='$&'>$&</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);