// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^#[0-9]*=").unwrap();
let string = "#1=stuff
#2=more stuff
...
#123=even more stuff";
let substitution = "<a href='$&'>$&</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}