re = /^#[0-9]*=/m
str = '#1=stuff
#2=more stuff
...
#123=even more stuff'
subst = '<a href=\'$&\'>$&</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result