$re = '/^#[0-9]*=/m';
$str = '#1=stuff
#2=more stuff
...
#123=even more stuff';
$subst = "<a href='$&'>$&</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;