# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d(?=(?:\D*\d){0,3}\D*$)/X/gm;t' <<< "+36 6 41 88 75 22"