using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d(?=(?:\D*\d){0,3}\D*$)";
string substitution = @"X";
string input = @"+36 6 41 88 75 22";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}