use strict;
my $str = '+36 6 41 88 75 22';
my $regex = qr/\d(?=(?:\D*\d){0,3}\D*$)/mp;
my $subst = 'X';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";