import Foundation
let pattern = #"\d(?=(?:\D*\d){0,3}\D*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"+36 6 41 88 75 22"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"X"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)