re = /\d(?=(?:\D*\d){0,3}\D*$)/m
str = '+36 6 41 88 75 22'
subst = 'X'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result