$re = '/\d(?=(?:\D*\d){0,3}\D*$)/m';
$str = '+36 6 41 88 75 22';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;