#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d(?=(?:\D*\d){0,3}\D*$)"
Local $sString = "+36 6 41 88 75 22"
Local $sSubst = "X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)