import re
regex = re.compile(r"\d(?=(?:\D*\d){0,3}\D*$)", flags=re.MULTILINE)
test_str = "+36 6 41 88 75 22"
subst = "X"
result = regex.sub(subst, test_str)
if result:
print(result)