# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!title\s*=\s*")\b([^"=\s]+)/{\1}/g;t' <<< "title = \"It's an interesting title.\",
title= \"Who's Afraid of Ms. Virginia Woolf?\",
title=\"What a crazy title\","