const regex = /(?!title\s*=\s*")\b([^"=\s]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!title\\s*=\\s*")\\b([^"=\\s]+)', 'g')
const str = `title = "It's an interesting title.",
title= "Who's Afraid of Ms. Virginia Woolf?",
title="What a crazy title",`;
const subst = `{\1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);