import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!title\\s*=\\s*\")\\b([^\"=\\s]+)";
final String string = "title = \"It's an interesting title.\",\n"
+ "title= \"Who's Afraid of Ms. Virginia Woolf?\",\n"
+ "title=\"What a crazy title\",";
final String subst = "{\\1}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}