re = /(?!title\s*=\s*")\b([^"=\s]+)/
str = 'title = "It\'s an interesting title.",
title= "Who\'s Afraid of Ms. Virginia Woolf?",
title="What a crazy title",'
subst = '{\\1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result