$re = '/(?!title\s*=\s*")\b([^"=\s]+)/';
$str = 'title = "It\'s an interesting title.",
title= "Who\'s Afraid of Ms. Virginia Woolf?",
title="What a crazy title",';
$subst = "{\1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;