# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w(?=\w{4})/#/gm;t' <<< "4f563a46jy7u35616
4f56sdfsddf
okmefiwmkiol
drejkskmilw
123434355454
34223"