use strict;
my $str = '4f563a46jy7u35616
4f56sdfsddf
okmefiwmkiol
drejkskmilw
123434355454
34223';
my $regex = qr/\w(?=\w{4})/mp;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";