re = /\w(?=\w{4})/m
str = '4f563a46jy7u35616
4f56sdfsddf
okmefiwmkiol
drejkskmilw
123434355454
34223'
subst = '#'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result