#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\w(?=\w{4})"
Local $sString = "4f563a46jy7u35616" & @CRLF & _
"4f56sdfsddf" & @CRLF & _
"okmefiwmkiol" & @CRLF & _
"drejkskmilw" & @CRLF & _
"123434355454" & @CRLF & _
"34223"
Local $sSubst = "#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)