const regex = /\w(?=\w{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w(?=\\w{4})', 'gm')
const str = `4f563a46jy7u35616
4f56sdfsddf
okmefiwmkiol
drejkskmilw
123434355454
34223`;
const subst = `#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);