import Foundation
let pattern = #"\w(?=\w{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
4f563a46jy7u35616
4f56sdfsddf
okmefiwmkiol
drejkskmilw
123434355454
34223
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)