import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w(?=\\w{4})";
final String string = "4f563a46jy7u35616\n"
+ "4f56sdfsddf\n"
+ "okmefiwmkiol\n"
+ "drejkskmilw\n"
+ "123434355454\n"
+ "34223";
final String subst = "#";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}