import re
regex = re.compile(r"\w(?=\w{4})", flags=re.MULTILINE)
test_str = ("4f563a46jy7u35616\n"
"4f56sdfsddf\n"
"okmefiwmkiol\n"
"drejkskmilw\n"
"123434355454\n"
"34223")
subst = "#"
result = regex.sub(subst, test_str)
if result:
print(result)